报错环境:springboot+gradle+pgSQL

问题和思路:启动项目新建服务时报错,对比原有的服务发现依赖库下少了pgSQL的驱动包

解决方法:在构建文件中添加pgSQL驱动依赖,本人使用的是gradle构建工具,于是在项目build.gradle中加入以下依赖

// postgresql驱动
runtimeOnly 'org.postgresql:postgresql'

重新运行服务,启动成功。

Logo

腾讯云面向开发者汇聚海量精品云计算使用和开发经验,营造开放的云计算技术生态圈。

更多推荐