1028 人口普查 (20分)

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过 200 岁的老人,而今天是 2014 年 9 月 6 日,所以超过 200 岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数 N,取值在(0,10​5​​];随后 N 行,每行给出 1 个人的姓名(由不超过 5 个英文字母组成的字符串)、以及按 yyyy/mm/dd(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:

5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20

输出样例:

3 Tom John

不是很难,但使用python编写的程序最后一个测试点超时,查阅了其他人的结果之后,应该是喜闻乐见的python效率低环节(手动滑稽),因此除去python代码之外,还贴上了一份 大佬编写的C++代码。

python代码(测试点5超时):

#要输入的人数
n=int(input())
#用来存放符合要求的出生日期
people=[]

#依次进行输入
for i in range(n):
    name,date=input().split(' ')
    #符合要求的日期加入列表中
    if date>='1814/09/06' and date<='2014/09/06':
        people_info=[]
        people_info.append(name)
        #将日期按年、月、日拆分
        for j in date.split('/'):
            people_info.append(j)
        people.append(people_info)

#年、月、日作为三个关键字段进行升序排序
#生日日期最小的即为最年长者
#生日日期最大的即为最年幼者
people=sorted(people,key=lambda x:(x[1],x[2],x[3]),reverse=False)
#如果没有年龄合格的人,就输出0
if len(people)==0:
    print(0)
else:
    #按要求输出
    print(str(len(people))+' '+people[0][0]+' '+people[-1][0])

大佬的C++代码:

链接:https://blog.csdn.net/qq_40941722/article/details/94429909

 

#include <iostream>
#include <stdio.h>
#include <cstring>
using namespace std;

const char maxInputBirth[11] = "2014/09/06";
const char minInputBirth[11] = "1814/09/06";

int main(){
    int n, count = 0;
    char name[6], birth[11];
    char maxName[6], minName[6];
    char maxBirth[11] = "2014/09/06", minBirth[11] = "1814/09/06";
    scanf("%d", &n);
    while(n--){
        scanf("%s %s", name, birth);
        if(strcmp(maxInputBirth, birth) >= 0 && strcmp(minInputBirth, birth) <= 0){
            count++;
            if(strcmp(maxBirth, birth) > 0){
                strcpy(maxName, name);
                strcpy(maxBirth, birth);
            }
            if(strcmp(minBirth, birth) < 0){
                strcpy(minName, name);
                strcpy(minBirth, birth);
            }
        }
    }
    printf("%d", count);
    if(count > 0)
        printf(" %s %s\n", maxName, minName);
    return 0;
}

 

 

Logo

腾讯云面向开发者汇聚海量精品云计算使用和开发经验,营造开放的云计算技术生态圈。

更多推荐