题目描述

小理现在有一份日历,但是这个日历很奇怪并不能告诉小理日期信息。小理现在有年和月,希望你能帮他计算出来这一年这个月有几天。

输入

输入共一行,两个整数,代表年和月,中间用空格隔开。

 

输出

一个整数,代表这一年这个月有几天。

样例输入1

2017 1

 

样例输出1

31

 

提示

1、3、5、7、8、10、12月有31天 4、6、9、11月有30天 闰年的2月有29天,平年的2月有28天。

 

来源/分类(难度系数:二星)

热身赛

 

完整代码展示:

# coding=utf-8
a,b=map(int,input().split())
c=[1,3,5,7,8,10,12]
d=[4,6,9,11]
if a%4==0 and a%100!=0 or a%400==0:
    if b in c:
        print(31)
    elif b in d:
        print(30)
    else:
        print(29)
else:
    if b in c:
        print(31)
    elif b in d:
        print(30)
    else:
        print(28)

 

代码解释:

a,b=map(int,input().split())

导入用户的年份a和月份b。

c=[1,3,5,7,8,10,12]

d=[4,6,9,11]

将31天和30天的月份分别储存在c,d中。

if a%4==0 and a%100!=0 or a%400==0:

    if b in c:

        print(31)

    elif b in d:

        print(30)

    else:

        print(29)

如果为闰年:分别判断月份是否在c,d中,如果在,则分别打印31,30,否则打印29。

else:

    if b in c:

        print(31)

    elif b in d:

        print(30)

    else:

        print(28)

如果不为闰年:分别判断月份是否在c,d中,如果在,则分别打印31,30,否则打印28。

 

运行效果展示:

9c757f4b9c28491aac4009836532904e.jpeg

 c35d13240ab04a64888ab146b01c28c5.jpeg

                      (声明:以上内容均为原创) 

 

Logo

腾讯云面向开发者汇聚海量精品云计算使用和开发经验,营造开放的云计算技术生态圈。

更多推荐