今天在虚拟机上安装了mongo,但是使用DG进行连接的时候报错:java.rmi.ConnectException: Connection refused to host: 127.0.0.1。这个问题很奇怪,DG测试连接可以通过,但是确认配置进行连接后显示正常,数据库可以被查询一部分,但是写操作被禁止,执行写操作就报错没有连接上。(忘记截图了,就看看文字吧)

出现的原因:

        根源是spring实现中,server端使用了主机名,linux在解析主机名时使用了与windows不同的逻辑。

解决办法:

// 虚拟机上执行命令:

hostname -i

// 如果返回的是127.0.0.1,需要修改为真实的IP地址

// 修改/etc/hosts

找到127.0.0.1       hostxxxxx这样的字样。把127.0.0.1改成真实的(就是你虚拟机的地址),可供其他机器连接的ip。修改保存即可

重新连接后,DG终于显示出正确的数据库信息了,可以正常使用 

Logo

腾讯云面向开发者汇聚海量精品云计算使用和开发经验,营造开放的云计算技术生态圈。

更多推荐