docker安装后,使用中经常出现:

Cannot connect to the Docker daemon at (unix:///var/run/docker.sock. Is the docker daemon running?) 

一、什么原因导致的:
触发此错误的一些原因包括:

The Docker daemon is not running.   Docker守护程序未运行。
Docker doesn’t shutdown cleanly.       Docker无法完全关闭。
Lack of root privileges to start the docker service.   缺少启动docker服务的root权限。

解决方法:

(1)在终端中执行 – unmask docker.

sudo systemctl unmask docker

如果docker被masked了,一般会有这样的提示:‘Failed to start docker.service: Unit is masked.’ 

(2)启动 start the docker daemon

systemctl start docker


(3)验证docker是否激活

systemctl status docker


如果出现以下内容,则已经激活了。

 

Logo

腾讯云面向开发者汇聚海量精品云计算使用和开发经验,营造开放的云计算技术生态圈。

更多推荐