将root用户的密码修改之后,再用Navicat连接mysql会报错,如图。


使用cmd却可以正常使用mysql,如图



解决方案:

重新修改下密码
mysql -uroot -proot
SET PASSWORD = PASSWORD('root');

或者控制台进去直接更新密码:

mysql -uroot -proot

update user set authentication_string = password('password'), password_expired = 'N', password_last_changed = now() where user = 'root';
flush privileges;

Logo

腾讯云面向开发者汇聚海量精品云计算使用和开发经验,营造开放的云计算技术生态圈。

更多推荐