使用 JDBC 方式访问 Hive时启动hiveserver2报错
Could not open client transport with JDBC Uri: jdbc:hive2://hadoop102:10000: java.net.ConnectException: 拒绝连接 (Connection refused) (state=08S01,code=0)
 原因是hiveserver2没有完全启动,需要多等待几分钟。
如果还没有解决:
  • 修改hadoop 配置文件
  • 先切换到hadoop目录下:  cd $HADOOP_HOME/etc/hadoop
  • 然后修改配置文件:  vim core-site.xml
  • 加入如下配置项  ( 主要是修改用户名,把proxyuser后的xxx换成你的linux系统的用户名)

<property>    

      <name>hadoop.proxyuser.XXX.hosts</name>    

      <value>*</value>

</property>

<property>    

      <name>hadoop.proxyuser.XXX.groups</name>    

      <value>*</value>

</property>

 ·重启reboot

重启后在hive目录下启动metastore:     hive --service metastore

注意: 启动后窗口不能再操作,需打开一个新的 shell 窗口做别的操作
启动 hiveserver2:    bin/hive --service hiveserver2
Logo

腾讯云面向开发者汇聚海量精品云计算使用和开发经验,营造开放的云计算技术生态圈。

更多推荐