ERROR org.apache.hadoop.ha.ZKFailoverController: Unable to start failover controller.
·

用jps查看java进程,发现没有DFSZKFailoverController进程
格式化zk,在zookeeper上创建hadoop-ha节点(就是目录)
hdfs zkfc -formatZK


启动zkfc(在所有namenode节点上)
hadoop-daemon.sh start zkfc
刷新namenode,会自动选出active
hdfs haadmin -failover nn1 nn2
https://blog.csdn.net/houzhizhen/article/details/44099825 参考地址
更多推荐
所有评论(0)